API unavailable


I am getting below error when trying to search for a company from https://developer.companieshouse.gov.uk/api/docs/company/company_number/readCompanyProfile.html#here2

Response status
0 error

Response body
Failure while contacting API. Some possible causes are connection problems or cross-origin resource sharing protection. Please check javascript domains registered against APIKey / OAuth2 registration.

Can anyone help on this?

One for Companies House. Looks like when Companies House changed the system to limit access e.g. link API keys to given IPs the “test” feature on the documentation was not updated. I see the same thing:

I think updating the documentation is the last thing on the priority list for them. I think some parts (e.g. the test feature on the documents API documentation) haven’t worked for some years now. (I just tested “fetch metadata” in the document api docs and got the same error as above which isn’t surprising).

Did you aver resolve this, Amol?