Basic questions from a complete novice

My plan is to extract companies information for a certain market segment so I can combine it with the person of significant control data to understand the age of directors and owners of an industry segment.

I think to do that I can connect Google Sheets to the companies house APIs, if I have a key.

I have made an account, logged in, clicked “create an application”, and tried on multiple laptops to do so in both “Test” and “Live” environments. But when the website says “application created” no application is visible in the platform, which is hampering me getting a Key to connect.

I know I’m working my way through a technical issue basically blindfolded by my technical incompetence, but this doesn’t feel like it is a “me” issue? What am I doing wrong?!

Any help appreciated


I’ve just tried here to see if it is a “you” issue.

I have no test applications on my account and trying to add a new one does the same for me as it does for you. It says the app is created but nothing appears.

I have two live applications and it allows me to add a third and it shows in the list fine. I am unable to delete those to test whether it would allow me to add from an empty list as those are in use but there does seem to be some issue.

Hope that helps you push forward.

There does seem to be an issue with the app creation. There is a separate thread here: