Internal Server Error - Document Service

Getting 500 - Internal server errors no matter what I try when trying to access: or any other document link.
I tried substituting with

and get the same error.

Headers are set as Authorization: {api-key} and Accept: application/pdf

Tried a few different ways Including postman, C# and Java and keeps giving the same 500

OK - Solved!

Issue is with postman and I suspect other apps and the way they deal with the auth header - but also inconsistent as it works fine with other CH services and so can seem suspect.

Most other calls work fine if you put the API Key in the header with simple: “Authorization” however for the document service, it needs to be base64 encoded and so: Authorization: Basic xxxxx=

On postman, turn off the Auth header you might have been using for other calls (which all work fine BTW) and replace with Basic auth using the API key in the username.

I think this trips people up (from what I’ve seen in other posts on the forum) as most of the API calls work fine with just the standard Authorization header but for the document service, it needs to be encoded or you get a 500 error - also potentially confusing as it’s an internal error rather than an authentication error.

Perhaps worth looking into and changing this error code?