Registered office address returning a 404


Right now, I think the registered-office-address API call is returning a 404 Not Found error for all company lookups.

For instance, trying the below should show up details for an active company, but I just get a 404:

curl --verbose -XGET -u apikey:
< HTTP/1.1 404 Not Found
< Date: Wed, 30 Dec 2020 21:32:13 GMT
< Content-Length: 0
< Connection: keep-alive
< Access-Control-Allow-Credentials: true
< Access-Control-Allow-Headers: X-RateLimit-Query, origin, content-type, content-length, user-agent, host, accept, authorization
< Access-Control-Expose-Headers: X-RateLimit-Window, X-RateLimit-Limit, X-RateLimit-Remain, X-RateLimit-Reset, Location, www-authenticate, cache-control, pragma, content-type, expires, last-modified
< Access-Control-Max-Age: 3600
< X-Ratelimit-Limit: 600
< X-Ratelimit-Remain: 597
< X-Ratelimit-Reset: 1609364207
< X-Ratelimit-Window: 5m
< Server: CompaniesHouse

This certainly used to work, so I think the API is misbehaving, unless somebody can figure out a mistake I’m making!



No issue here. I have just called it successfully and got back:-
{“etag”:“a9af0b75e0653484c1e40b907559360229e3bba5”,“kind”:“registered-office-address”,“links”:{“self”:"/company/08540541/registered-office-address"},“address_line_1”:“Unit 132 Henry House”,“address_line_2”:“275 New North Road”,“locality”:“London”,“postal_code”:“N1 7AA”}

you could also try:-{company_number}/registered-office-address

Just tried again and got the 404 again!

I can’t think of any reason I should get this - can you? I correctly get a 400 for a weird authorization header, and 401 for an invalid authorization header.

I get the 404 even with

Have you tried using the developer site?

Signin and go to the bottom of the page and use the “Try it out!”

Yes, I have tried using the developer site and I get a 404 error even on there.

    GET /company/08540541/registered-office-address HTTP/1.1


        Response status
        404 Not Found

        Response body

        Response headers
        x-ratelimit-limit: 600
        x-ratelimit-remain: 598
        x-ratelimit-reset: 1609512154
        x-ratelimit-window: 5m