API key not working

The interface has changed for generating an api key. I am trying to follow the instructions here Authentication

I have added a test application here https://developer.company-information.service.gov.uk/manage-applications/add

I have added a key using the New API client key form for the application. I have given it a name key

I call

curl -XGET -u "my API key value": https://api.company-information.service.gov.uk/company/00000006

replacing the “my API key value” with the API key value that it allows you to copy. But I still get {"error":"Invalid Authorization","type":"ch:service"}

I have tried different names ie username, api etc I have also tried adding and removing IP address. I still get the same response. What am I missing

If you are using an API key generated for a test application you need to use the testing urls instead of the standard API urls.

You can find the urls listed here the one you are looking for is https://api-sandbox.company-information.service.gov.uk

Hope that helps

1 Like

When I create an application for live it doesn’t appear on the Live Applications list, what do I need to do to make it visible?

I’ve had an issue similar to this before with a test app, I just had to sign out and back in, sounds stupid I know but it worked for me.

If that doesn’t work you may need to talk to a moderator, I’ve just tested creating a live app and it showed straight away

Logged in and out several times nothing, tried creating one again this is the end result, nothing

Seems like an account issue more than a API issue. I would create an new topic for this issue and see if you can get a moderators help