Are there service issues with the public information API (Registered company address)?

I keep getting an internal server error 500 when submitting requests - is this a known issue, or am I doing something wrong?
An example url is
The API key authorisation appears to be working

You must use the full 8 character company number. The example you gave only has 7 chars so is not a valid company number.

Sorry, bad example. I have tried with and still get a 500 error

I have just checked with:-
curl -u apiKey:
and got back the following:-
{“etag”:“1e71547dbd7c8ba6e6ec105528300881338ba609”,“kind”:“registered-office-address”,“links”:{“self”:"/company/06789099/registered-office-address"},“address_line_1”:“Office 309, Wizu Workspace The Leeming Building”,“address_line_2”:“Ludgate Hill”,“country”:“England”,“locality”:“Leeds”,“postal_code”:“LS2 7HZ”}

Hi Mark, I have got it working now, but it needed an apiKey without a restricted ip address. For some reason the restricted IP doesn’t seem to work. I have seen this reported on another thread here.

Registered-office-address 500 Error when restricted by IP - API Issues - Companies House Developer Forum (