Cannot view pdf properly in filing history document metadata

Url = “

response -: left hand side
saving pdf -: roght hand side

can you please give me the solution for fixed above issue or
if i tried way is wrong please give another way to fixed it.

You appear to be re-reporting the same thing as this thread:

This seems to be nothing to do with Companies House. Unfortunately you have not said how you are getting this information e.g. what particular program / system you’re using to make the call to Companies House. You’ve also not said how you are processing / storing / saving the returned data nor how you have tried to view it.

PDF is a binary format. You seem to have dumped this to text (on the left of your picture) so depending on what you’ve done you have probably corrupted this.

I can’t advise you further but I have tested the link you provided and am able to download the PDF and view this without problems. I used curl on a linux system and the following command to obtain the PDF data:

curl -L -uMY_API_KEY: "" > test.pdf

The -L means “follow returned redirects”, MY_API_KEY is my actual API key (and the “:” is because the -u argument expects a http basic username and password) and the “> test.pdf” redirects output to a file. I can simply open that file in any pdf viewer (e.g. most browsers, Adobe Acrobat DC / Reader etc.) and see the contents.